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�CHAPTER 1����



Introduction











What is JWP Anyway?

	JWP is a freeware Japanese word processor, available free to anyone under the terms of the GNU General Public License.  You are welcome to make a copy for your own uses, as well as to distribute it to other people.  The GNU General Public License binds you to the agreement that you always distribute full copies of the pro�gram, and that you can charge a distribution fee for distributing it.  However, no part(s) of JWP may be included in any commercial product, nor may any commercial product include portion(s) derived from part(s) of JWP, without the explicit permission of the respective copyright holder(s).

	When designing JWP, the highest priority was given to basic Japanese word processing functions.  It does not (yet) have fancy font-control and advanced layout features found in other high-end English word processors.  You can always use Japanese PageMaker™ for that purpose.

	It is assumed that JWP will be used mainly to handle Japanese text with an occasional English word or two.  The program is not optimized to handle writings with large amount of English text and a few Japanese char�acters; for those circum�stances, it is much better to employ a normal English word processor and paste in Japanese bitmaps.  (See page �pageref CutAndPasteBitmap�21� for more details)

	Please support JWP in any way you feel like (sending a fan mail to some of the people involved in the project sounds nice). 





What is the GNU General Public License?

	A description of the GNU General Public License is shown below, taken directly from the License document itself.  You should have a copy of the License together with this package.  They are in the files called GNUGPL.WRI (Windows Write format), GNUGPL.DOC (Microsoft Word for Windows 2.0 format), GNUGPL.RTF (RTF format) and GNUGPL.TXT (straight text).



	The license agreements of most software companies try to keep users at the mercy of those companies.  By contrast, our General Public License is intended to guarantee your freedom to share and change free software — to make sure the soft�ware is free for all its users.  The General Public License applies to the Free Software Foundation’s software and to any other program whose authors commit to using it.  You can use it for your programs, too.

	When we speak of free software, we are referring to freedom, not price.  Specifically, the General Public License is designed to make sure that you have the freedom to give away or sell copies of free software, that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

	To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights.  These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

	For example, if you distribute copies of a such a program, whether gratis or for a fee, you must give the recipients all the rights that you have.  You must make sure that they, too, receive or can get the source code.  And you must tell them their rights.

	We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

	Also, for each author’s protection and ours, we want to make certain that every�one understands that there is no warranty for this free software.  If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors’ reputations.



All these basically mean that you are free to get a copy of the program if you want, including the full source code.

	Whenever a specific copyright notice conflicts with the GNU General Public License, the specific copyright provision(s) will take precedence over the GNU General Public License.

	No part(s) of JWP may be included in any commercial product, nor may any commercial product include portion(s) derived from part(s) of JWP, without the explicit permission of the respective copyright holder(s).





Disclaimers

	Because this program is free software, it is distributed in the hope that it will be useful, but Without Any Warranty; without even the implied warranty of Merchantability or Fitness For A Particular Purpose.  This means that if you lose millions of dollars because you used the program, tough.  So there.

	You should choose the About JWP command from the Help menu to read some of the background information concerning JWP.  In particular, you can:



		1) Read the disclaimer the comes with JWP

		2) Read the copyright notices for JWP

		3) Read the GNU General Public License

		4) See the names of people involved in JWP’s development



You are also encouraged to contact the people involved in the JWP project.  They may have resources and software that you’ll like.



�CHAPTER 2











Installing JWP











Hardware and Software Requirements

	JWP is designed to be run on IBM PC and compatible computers under the Microsoft Windows operating environment, version 3.1 or higher. As a result, a computer with an 80286 CPU or higher is required.  Although you can run Windows with 2 MB of RAM in the computer, the minimum recommended set-up is 4 MB for acceptable performance.

	JWP is very processing-intensive.  A faster computer will greatly enhance the program's responsiveness.  It is highly recommended that you use at least a 33 MHz 80486 computer.  Slower computers may give annoying delays, especially when working with large paragraphs.





Installing and Running JWP

	To install JWP, follow the steps outlined below.  I realize that this installation process is more manual than necessary; however, since JWP is a freeware project, I do not have the option of bundling a commercial installer.  Maybe someday I’ll write one. . .  Meanwhile, sorry for the inconveniences.



Important:	JWP files come in Zip Archives.  There are unarchive programs freely available on the Internet, both for DOS and for Windows.  A popular DOS unarchiver is PKUNZIP.EXE; a popular Windows one is WINZIP.EXE.



Installation Steps



Step 1:	Create a new directory for JWP.

	For example, if you want to call the directory ‘JWP’ in the C: drive, you should type (in DOS):



C:  <Return>

MD \JWP  <Return>



	or (in the Windows File Manager):



Choose the File menu

Choose the Create Directory command

type  C:\JWP  <Return>



Step 2:	Switch to the JWP directory.

	Double-click the directory in the Windows File Manager or type the following in DOS:



	CD \JWP  <Return>



Step 3:	Unpack all the ‘zip’ files into the new sub-directory.

	For example (in DOS):



	PKUNZIP JWPPROG.ZIP  <Return>

	PKUNZIP JWPFONTS.ZIP <Return>

	PKUNZIP JWPDICT.ZIP  <Return>

			:

			:

	If you use a Windows unarchiver, read the instructions that come with the software.

	If you have obtained JWP on diskettes with all the files already unpacked, copy all the files into the new sub-directory.  For example (in DOS):



	COPY A:*.* <Return>



	for each diskette.



Step 4:	Make sure that you have all the files necessary for JWP.  A list of all the files can be found at the end of this chapter, as well as in the file 'FILES.LST.

	The DOS command “DIR/P” will display a list of all the files in the current directory.  Alternatively, look in the Windows File Manager.



Step 5:	Move the file CTL3DV2.DLL to your Windows System directory.  In many systems, the Windows System directory is something like C:\WINDOWS\SYSTEM.

	To move the file, you should drag the file into the Windows System directory (with File Manager) or copy it via a DOS command like:



	COPY CTL3DV2.DLL C:\WINDOWS\SYSTEM <Return>



	If you already have the file CTL3DV2.DLL in your Windows System directory, you should double-check the dates on the two files.  Use the most recent one.



Step 6: 	ERASE the file CTL3DV2.DLL from your JWP directory.  Due to a         command from Microsoft Oh-High, JWP may not work if a copy of         CTL3DV2.DLL is left in the program directory.

	You can erase the file from within the Windows File Manager, or via a DOS command like:



	ERASE  CTL3DV2.DLL  <Return>



Step 7:	JWP is ready to run.  Unlike many commercial Windows programs, JWP does not automatically install itself into the Program Manager.  It is necessary for you to use the New command under the File menu and add a program item into the appropriate program group.�  You can now run JWP by double-clicking on the JWP icon.





�What Files Should I Get in the Package?

	You must have the following files in order to install and run JWP:

		JWP.EXE		�symbol 183 \f "Symbol"�� JWP program

		JWP.HLP		�symbol 183 \f "Symbol"�� JWP help file

		CTL3DV2.DLL	�symbol 183 \f "Symbol"�� DLL to create 3D dialog boxes (Microsoft)

		MAKEINI.EXE	�symbol 183 \f "Symbol"�� Program to create user initialization file

		EDICT		�symbol 183 \f "Symbol"�� Jim Breen’s Japanese–English dictionary

		EDICT.JDX		�symbol 183 \f "Symbol"�� Index to EDICT

		K16X16.F00	�symbol 183 \f "Symbol"�� 16×16 kanji font

		K24X24.F00	�symbol 183 \f "Symbol"�� 24×24 kanji font

		K48X48.F00	�symbol 183 \f "Symbol"�� 48×48 kanji font

		KINFO.DAT		�symbol 183 \f "Symbol"�� Kanji information data

		KINFOSTR.IDX	�symbol 183 \f "Symbol"�� Index to KINFO.DAT (sorted by stroke counts)

		KINFOBSH.IDX	�symbol 183 \f "Symbol"�� Index to KINFO.DAT (sorted by bushu’s)

		WNN.DCT		�symbol 183 \f "Symbol"�� Kana-to-kanji conversion dictionary

		WNN.IDX		�symbol 183 \f "Symbol"�� Index to WNN.DCT

		RADKANJI.DAT	�symbol 183 \f "Symbol"�� Michael Raine’s Radical Lookup Database

		RADKANJI.IDX	�symbol 183 \f "Symbol"�� Index to RADKANJI.DAT

		STROKNJI.DAT	�symbol 183 \f "Symbol"�� Michael Raine’s Radical Lookup Database

		STROKNJI.IDX	�symbol 183 \f "Symbol"�� Index to STROKNJI.DAT



	The following files should come with the JWP package, but they are not critical.  If you do not have them, check with the place you obtained the JWP package from.

	MANUAL.DOC	�symbol 183 \f "Symbol"�� This User’s Manual (in Microsoft Word for Windows 2.0 format)

	MANUAL.EXE	�symbol 183 \f "Symbol"�� Self-viewing version of this User’s Manual (Replica 1.0)

	COPYRGHT.TXT	�symbol 183 \f "Symbol"�� Other copyright notices (straight text)

	GNUGPL.WRI	�symbol 183 \f "Symbol"�� The GNU General Public License (in Windows Write format)

	GNUGPL.DOC	�symbol 183 \f "Symbol"�� The GNU General Public License (in Microsoft Word for Windows 2.0 format)

	GNUGPL.RTF	�symbol 183 \f "Symbol"�� The GNU General Public License (in RTF format)

	GNUGPL.TXT	�symbol 183 \f "Symbol"�� The GNU General Public License (straight text)

	CJK.INF	�symbol 183 \f "Symbol"�� Ken Lunde’s document on Japanese information processing

	FILES.LST	�symbol 183 \f "Symbol"�� List of all files that come with the package

	GLOSSARY.DAT	�symbol 183 \f "Symbol"�� User glossary

	BTNMAD.EXE	�symbol 183 \f "Symbol"�� Recreational program: Button Madness!

	BTNMAD.DOC	�symbol 183 \f "Symbol"�� Documentation to Button Madness!

	PUZZLE.EXE	�symbol 183 \f "Symbol"�� Recreational program: Puzzle

	PUZZLE.HLP	�symbol 183 \f "Symbol"�� Help file for Puzzle

	MB.EXE	�symbol 183 \f "Symbol"�� Recreational program: Mile Bones



	The following files may come with your package.  They are not part of the standard JWP distribution and are likely to be personal files left over by the previous user from whom you received this package.  It is up to you whether to keep them or not.

		USERDICT.DCT	�symbol 183 \f "Symbol"�� User Kana-to-kanji conversion dictionary

		CNVCACHE.SAV	�symbol 183 \f "Symbol"�� Kana-to-kanji conversion choices
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Entering Text











How to Type Japanese and English Text

	JWP is designed to be as “modeless” as possible and as “direct” as pos�sible.  Many Japanese word processors and editors on PC’s, Macintosh’s and UNIX systems use a separate “input area” at the bottom of the screen.  The user types in Japanese words in romaji, such as:



		watashi ha nihongo wo benkyou shite imasu.



The user then presses some “convert” button, and the romaji-ized sentence is converted to kanji’s and entered.  In the shareware version of MOKE� for the IBM PC, for example, hiragana’s will be entered when the user presses the space bar.  If the user types a single word and presses F2, then the word’s kanji reading will be entered.

	This is a rather “modal” approach to kana-kanji conversion.  The approach taken by JWP is different; when you first run it, you will instead see something that looks very much like a rip-off of Word for Windows.  There is an iconbar on top of the screen:



�

	á	á	á	á	á	á	á	á

	Font-change	English/	JASCII	convert	font	toggle	special	writing

		kana input		to kanji	attributes	glossary	symbols	direction

The font attribute buttons (bold, italics, etc.) and the font box on the left are grayed out.  They are not supported by the current version of JWP, and they are reserved for future implementations.

	Clicking on the English button will enter English alphabetic letters on everything you type; just like a normal English word processor.  Clicking on the hiragana button will enter hiragana’s.  There is also a hot-key that you can define so that, whenever you press it, JWP will toggle between entering English and hiragana’s.  That hot-key is originally assigned to F4, but you can change it easily.

	Clicking on the JASCII button will enter English letters and other normal ASCII as JASCII. There is also a hot-key that can be defined so that, when pressed, JWP will toggle between entering ASCII and JASCII.  That hot-key can also be changed.

	Start typing the above sentence in JWP.  Type:



		watashihanihongowobenkyoushiteimasu.



You will see hiragana’s appearing on the screen while you type.  If you look down to the status bar while typing, you will actually see the characters you typed.  The complete sentence will come out to be:



		�



	JWP will enter a hiragana automatically as long as there are no ambi�guities.  For example, an “n” can either be the beginning of  “na ni nu ne no” (�) or the hiragana �.  You can also type “n’” for �; that will make it unambiguous.  Because the program cannot decide which kana character you are entering, all it can do is to register that you have typed an “n”.  You will see that the letter “n” appears in the status bar.  When you type an “a” immediately afterwards, for example, the hiragana � will be entered.  When you type a “t”, however, JWP is aware of the fact that there is no hiragana starting with “nt”, and it will deduce that the first “n” should be interpreted as the hiragana �. It will then enter an � and register the letter “t”, so that, when you press an “a” later, the hiragana � will be entered.

	You can enter the small hiragana’s by putting a plus sign (“+”) in front of them.  For example, “+a” will enter �.  “+tu” will enter �.  There is another short-cut for �, however.  If you type a leading letter twice (such as “tt”, “ss” etc.), JWP will assume that you want to enter the first letter as a �.  For example, typing “tukatte” will enter:

		�

The only exception is "nn" which does not generate a  �.  If you type “tennou”, JWP will generate � instead of �.

	JWP understands shorthands such as “sha”, “kyu”, etc.  “Shi” can be used in place of “si”.  “Chi” and “ci” can be used in place of “ti”.  “Tsu” and “tzu” can be used in place of “tu”.

	Several English symbols have Japanese equivalents, and several Japanese symbols have equivalent combinations of English key-strokes.



English�Japanese��Comma (,)����Period (.)����Open quote (‘)��embed MSDraw \* mergeformat �����Close quote (’)����Dash (–)����f–����y=����

Most of the other symbols in the ASCII character set will be translated to the equivalent character in the Japanese JIS character set.

	You enter katakana’s by typing the entire hiragana in Capitals. For example, “KU” will enter the katakana �.  Entering katakana’s for � might be a little more complicated.  As you will see, capitalized words will be converted to kanji’s in JWP, so the program must know whether the user actually means to enter the character �, for example, or whether he actually means to enter the kanji �.  JWP resolves this conflict by assuming that, if any non-capitalized letters follow the capitalized letter, it will be assumed as a kanji conversion. If capitalized letters follow, it will be assumed as a katakana. In order to enter �, however, you must type “A” and press the convert hot-key (originally set to F2).

	The default English font is Times New Roman 12 points, but you can easily change this font to another you choose.  Pressing the “tab” key will skip the cursor to the next hiragana position.  This is mainly used for align�ing kanji’s to fixed positions after English text, because English text usually do not end in neat Japanese cell boundaries.









How to Enter Kanji’s

	You start a kanji conversion by typing the first letter of the first kana of a word in capital letter.  JWP will highlight that hiragana, and every hiragana you type afterwards will also be highlighted.  The highlight indi�cates that a kanji conversion is taking place.  When JWP reaches a point where it is impossible to find a conversion for the string of hiragana’s you have just typed in, it will replace the longest string of hiragana’s that can be converted to kanji’s.

	This is especially desirable in writing Japanese.  For example, typing “Watashi” will enter the three hiragana’s �, but they will be highlighted.  Type in “ha”, and the character � will appear at the end of �, high�lighted also.  As the characters �, � and � are entered, JWP realizes that it is possible to delay the conversion because there are kanji’s whose readings start with � (e.g. �), � (e.g. �) and � (e.g. �).  But, after searching the database, it will realize that there are no kanji’s starting with �.  The longest hiragana string will be converted, in this case �.  The char�acter � will stay where it is.

	Sometimes, the longest reading may not be the desired one.  In that case, pressing F2 (or choosing Convert from the Kanji menu) will force a conversion right at that point.

	When hiragana’s are converted to kanji’s, the choices are listed on the kanji list.  The kanji list can be detached and floated around the desktop, or it can be placed on the top or at the bottom.  By default, the first item on the list is chosen.  Pressing F2 will skip to the next item.  Pressing the hot-key for backward conversion (originally set to Shift�F2) will skip to the previous item.  You can also use the scrollbar under the kanji list to run through a long list quickly.  Clicking on an item in the list will automatically select it.  The last choice will always be the kana reading of the kanji so that you can revert back to the original kana string if necessary.

	JWP will also remember the last choice you have made on this particu�lar kana-to-kanji conversion.  Any subsequent conversion of the same hiragana pattern will convert to the last kanji that you picked.  For example, to enter the above sentence with kanji’s, type:



		WatashihaNihongowoBenkyoushiteimasu.



Notice that, as soon as “Watashiha” is typed, it is replaced by ��.  There are two possible readings for �, so the first one (which happens to be the correct one) is chosen.  The whole sentence comes out as the following:



		�



	Start every kanji word with capitals. “Nihongo” will be rendered �.  Notice also that you don’t have to press F2 even once.  Sometimes you will have to, though.  Pressing the hot-key after the conversion will switch to the next choice.  Of course, both � and � has only one kanji reading.  Try out other ones, such as �, �, etc.

	On the other hand, pressing F2 while selecting either ASCII or JASCII text will toggle that piece of text between ASCII and JASCII.





How to Use the Input Line Editor

	JWP's native input method may not be the preference of every user.  You may prefer a more “traditional” input style, i.e. using the Space Bar to convert a line of buffer text to kanji and the Return key to flush the buffer into the file window.  An “Input Line Editor” is included in JWP to facilitate such an input style.



Toggling the Input Line Editor Window

	The Input Line Editor can be toggled on and off with by pressing the “Toggle Input Editor” hot-key (defaulted to F5) or by choosing the Input Editor command from the View menu.

	When the Input Line Editor is visible, you can use the “Toggle Active Input Window” hot-key (defaulted toCtrl-Z) to toggle between the Input Line Editor window and the current file window.  Alternately, you can simply click anywhere in the desired window. Both hot-keys can easily be customized.

	When the Input Line Editor is active, the cursor position in the current file represented by making the character directly after the insertion point with a red-ish color. 



Using the Input Line Editor

	The Input Line Editor will only recieve input when it is active.  If active, it will capture all keystrokes and any input from the dialog windows with the exception of the Dictionary dialog.  Whenever an Insert to File button is pressed, from any of the kanji lookup functions, the text will be inserted into the Input Line Editor instead.

	All hot-keys are active inside the Input Line Editor.  You enter English text, hiragana's, katakana's and kanji's in a similar manner as in the file window.  Most directional keys work the same, except for the following:



Return	Immediately insert all the text within the Input Line Editor into the current file.



Space Bar	Highlight all the text within the Input Line Editor for conversion and start the conversion process, except when a kanji conversion has already taken place (see below).



Backspace	If the Input Line Editor is empty, will delete the previous character in the active file window.



In addition, when a kanji conversion has taken place:



Space Bar	Select the next kanji in the kanji list.

Right Arrow	Select the next kanji in the kanji list.

Down Arrow	Select the next kanji in the kanji list.

Shift-Space Bar	Select the next kanji in the kanji list.

Left Arrow	Select the previous kanji in the kanji list.

Up Arrow	Select the previous kanji in the kanji list.

Home	Select the first kanji in the kanji list.

End	Select the last kanji in the kanji list.



For example, to enter the sentence “�” into the current file, either of the following is recommended:



1)	Make sure that the Input Line Editor is visible and active, type into the editor window:



koreha  <Return>

nihongo  <Space Bar> <Return>

desu.  <Return>



2)	Make sure that the Input Line Editor is visible and active, type into the editor window:



koreha  <Return>

nihongo  <Space Bar>   desu.  <Return>





How to Define New Kana-to-Kanji Conversions

	Although the kana-to-kanji conversion dictionary that comes with JWP is comprehensive, it is always the case that certain conversions impor�tant to some users are not included.  You can supplement that standard con�version dictionary with your own conversions, and you can define these user conversions by choosing User Conversion from the Utilities menu.

	Two lists in the dialog box will show up.  The kana readings of all cur�rently defined user conversions will be listed on the left. When a reading is selected, the kanji’s associated with it will be listed on the right.  You can add a new user conversion by pressing the Add button.  You can also edit any existing user conversion by double-clicking on the entry or selecting it and pressing the Edit button.

	Care must be given when adding a kana reading for a user conversion.  If you enter all hiragana’s, then those particular kanji’s associated with it will only match that precise hiragana string.  However, you can put one (and only one) of the following letters at the end of the hiragana reading:



		u k g s z t d n m h b p r



These letters correspond to the first letter of the romaji representation of the ending kana if the reading is categorized under the � group.  For example, the kana reading “�k” will match the strings �, �, �, � or �.  Kanji’s assigned to this reading will match strings such as:



		�, �, �, etc.





How to Change Paragraph Formatting

	Each paragraph can have its own formatting.  In the current version, paragraph formatting is limited to Indentations and Line Spacing.

	The ruler on top of every file window shows the cell boundaries for Japanese characters as well as a few triangles indicating the indentations of the current paragraph.  The left triangle is divided into two halves; the upper half indicates the left indentation of the first line of the paragraph, while the lower half indicates the left indentation of the rest of the paragraph.  The right triangle indicates the right indentation of the paragraph.

	To indent the entire paragraph by three characters, for example, you click on the lower half of the left triangle, dragging it out to the third charac�ter position, and then releasing the mouse button.  You will see the para�graph being reformatted.  To indent the paragraph inwards from the right margin, drag the right triangle instead.

	Alternatively, you can change any paragraph formatting parameter, including line spacing, by choosing Paragraph from the Format menu.  A “1.5” line spacing, for example, will put half a line of blank space after each line in that paragraph.

	Remember that, however, the First indentation in this dialog box refers to an offset from the Left indentation.  For example, if the left margin of your paragraph is indented by 4 characters, the number “2” will indent the first line by 6 characters (i.e., 4 + 2).  On the other hand, the number “–2” will indent first line by only 2 characters (i.e., 4 – 2).





How to Use the Draft View

	Because mixing English text with Japanese text requires quite a lot of formatting, entering English text can be slow, especially on slower systems.  The “Draft View” will display and format all English text in the standard Windows font, which will be a little faster than a more WYSIWYG� view.  It is strongly recommended that you use the Draft View when entering large amount of English.  You can toggle between the Draft View and the standard view by choosing Draft View from the View menu.  You can also assign a hot-key for this function, if you switch between views on a regular basis.
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Moving Around the Document







How to Move Around Using the Keyboard



Key�Function��Left-arrow�Move left by one character��Right-arrow�Move right by one character��Up-arrow�Move to the previous line��Down-arrow�Move to the next line��Ctrl-left-arrow�Move left by one word��Ctrl-right-arrow�Move right by one word��Home�Move to the beginning of the line��End�Move to the end of the line��Ctrl-Home�Move to the beginning of the file��Ctrl-End�Move to the end of the file��PgUp�Move up by one screenful��PgDn�Move down by one screenful��Ctrl-PgUp�Move to the top of the screen��Ctrl-PgDn�Move to the bottom of the screen��Ctrl-Return�Insert a page-break.  The text following will always start a new page.��Shift�Return�Insert a soft return.  The text following will still be in the same paragraph��How to Jump to a Particular Page

	To jump to any page in the file, choose the Goto command from the Edit menu.  You can:

·	Jump to a particular page number

·	Jump to the beginning of the file

·	Jump to the end of the file





How to Select Text

	You can select text by moving the cursor while pressing the Shift key.  Any text selected will be highlighted.  You can also select text by clicking on the file window with the mouse and dragging it.  Text selection is critical for many JWP features, including kanji info, cut and paste, formatting, etc.

	If you choose Select All from the Edit menu, the entire file will be selected.  The cursor will move to the end of the file.





How to Use Cut And Paste

	You can delete, copy or move blocks of text through a process called “Cut and Paste”.  To delete or move a block of text, select it and choose Cut from the Edit menu or press Shift�Del.  The text will be cut into the Windows clipboard.  You can then insert it into another position or even another file by choosing Paste from the Edit menu or pressing Shift�Ins.

	To copy a block of text, select it and choose Copy from the Edit menu or press Control�Ins.  The text will be copied into the Windows clipboard and will also remain in the file.  You can then insert it into another position.

	If you run a “clipboard viewer”, such as the one supplied with Windows, you will notice that the data selected into the clipboard exists in several formats. First of all, the Text and OEM Text formats will show only text, without any formatting, in any standard Japanese coding format you have chosen.  You can set the clipboard coding format with Options from the Utilities menu.

	The Owner Display format will show the data fully formatted within the clipboard viewer’s window.  If the clipboard window is resized, the text will be reformatted to fit in the new window size.  All formatting will be retained.  You will be able to see Japanese text as is.

	The Bitmap format is simply a bitmap snapshot of the text you have selected, rendered in exactly the same manner as JWP does in the file win�dows. You can run PaintBrush or some other bitmap program to paste it in as a picture.  It is particularly useful in situations when you want to paste in a paragraph or two of Japanese text into an English word processor, such as Word for Windows.�  It is recommended that you change the display kanji font to a higher resolution font (such as 24×24 or 48×48) before creating a bitmap.  You can change the display kanji font with the Kanji Fonts command from the Utilities menu.





How to Undo and Redo Changes

	Regardless of how easy it is to enter a kanji into a computer, it is still (in my opinion) much more time-consuming than entering English charac�ters.  Because of this, it will be rather dangerous if JWP does not have a comprehensive undo feature; a user can accidentally delete a kanji character and spend the next 20 minutes searching for it again.

	For your protection, JWP automatically retains the changes you have made to a document so that you can “undo” them if necessary.  JWP also saves all changes into the document file so that you can undo them in later sessions.  By default, all changes are retained.  If JWP runs out of memory to store changes, it will delete the oldest change you have made to make room for new changes.  You can limit the number of changes that JWP will keep by choosing Options from the Utilities menu.  You can also tell JWP to trim off old changes when saving the file (in the JWP Normal format) or retain the changes so that you can undo them later.

	To undo the last change, choose Undo from the Edit menu or press Alt�Backspace.  You can “redo” this change later by choosing Redo from the Edit menu or pressing Alt�Shift�Backspace.  Remember, though, that all changes you have “undo-ed” will disappear once you make a new change to the document and you will no longer be able to redo them.





How to Search for and Replace Text

	Search and Replace functions are accessed through the Edit menu.  You can assign a hot-key to the Search, Replace, and Find/Replace Next functions.

	You have the option of ignoring all case (default), equating English alphabetic letters in the JIS character set with normal English alphabetic letters (default), searching the entire file, and wrapping around when the search hits the bottom of the file.  In Replace, you can also turn off confirma�tions and replace the entire file.

	One of the most powerful features of JWP is the support of “regular expressions”.  A regular expression gives you amazing power in searching and replacing text throughout the file.  You must turn on the Regular Expression check box in order for JWP to recognize a search string as a regular expression.  The following characters have special meanings when inside a regular expression (JIS equivalents will also work):

Character�Meaning��^�Matches the beginning of a line��$�Matches the end of a line��*�Matches many characters��?�Matches exactly one character��\b�Matches a hard page break��\n�Matches a soft return��\p�Matches the end of a paragraph��\t�Matches a tab��\x�Matches any hiragana or katakana��\k�Matches any kanji character��\a�Matches any English alphabetic letter��\�Escapes the following character (as long as it is not n, p, t, x, k and a) so that it loses its special meaning, if any.  For example, \$, \?, \\, etc.��

In addition, any character grouped within a pair of square brackets will match exactly one character within the group.  For example,



[abc]	Matches either ‘a’, ‘b’ or ‘c’

[a-def-h]	Matches anything within the range ‘a’ to ‘d’, the character ‘e’, or the range ‘f ’ to ‘h’

[-m]	Matches anything before and including ‘m’

[m-]	Matches anything after and including ‘m’



All of the English characters above can be replaced by a kana, a kanji, or any of the standard symbols in the JIS character set.  The JIS ordering is used to compare the relative positions of characters.  All ASCII characters come before JIS characters.  For example,



	�



will match any of the following:



	Any English alphabetic letters and symbols in the ASCII character set

	�



	If an exclamation mark (!) is placed at the beginning of the group, then the expression will match anything not within the group.  For example,



	[!a-m]		Matches anything not within ‘a’ to ‘m’



Anything placed within a pair of parentheses can be divided into “substrings”, separated by a comma (either the English comma ‘ , ’ or the Japanese comma ‘ �’).  For example,



	(abc,def,ghi)	Matches the strings ‘abc’, ‘def’, or ‘ghi’



One practical use of this structure is to search for a Japanese string regard�less of whether it has been rendered in kana or kanji.  For instance, the regular expression:



	�



will match either � or �.

	Finally, a pair of curly brackets ‘{}’ have meaning only when you are performing a replace.  In the replacement string, you can indicate that sub�strings from the original string should be placed within the new replacement string.  Curly brackets in the search string are numbered sequentially, start�ing from one, and are represented by placing a number between two curly brackets, e.g. “{1}”.  You can have up to 9 curly text strings enclosed in curly brackets within the search string.

	The numbering is depth-first, meaning that a pair of curly brackets enclosed within another pair is numbered before curly brackets following the enclosing pair are numbered.  For example, in the regular expression:



	{ a { bc { def } g { hi } } jk { lm } }



	{1} = ‘abcdefghijklm’		{4} = ‘hi’

	{2} = ‘bcdefghi’			{5} = ‘lm’

	{3} = ‘def’
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Managing Kanji’s







How to Get Information About a Kanji Character

	You can get very complete information about any kanji character in JWP.  First select the kanji character you want, then choose Get Info from the Edit menu.  A dialog box will pop up showing, among others:

1)	a large picture of the kanji

2)	its stroke count

3)	its bushu (both in number� and in actual bushu)

4)	its JIS coding (in hex digits)

5)	its Jouyou (�,“common”) grade level�

6)	its index number, if any�, in the Modern Reader’s Japanese-English Character Dictionary,  edited by Andrew Nelson

7)	its index number, if any, in the New Japanese-English Character Dictionary,  edited by Jack Halpern

8)	its On reading(s) (�) and Kun� reading(s) (�), if any

9)	its meaning(s) in English and other related information, if available

A bracketed hiragana string in the readings indicates an okurigana. Get-Info is also available in the dialog boxes of many other character look-up features of JWP.

	The “Kanji Info” database is being main�tained by Jim Breen� in Australia (who also produced the Japanese–English dictionary).  The latest version of the database can always be downloaded via anonymous FTP from ftp.cc.monash.edu.au.

	Jim has also developed, among other very useful Japanese software packages, a “Japanese File Viewer” called JREADER that offers dictionary and kanji info support (look into ftp.cc.monash.edu.au).  It is possible for you to keep one single copy for both programs.�  (See also page �pageref OneCopyOfDictionary�29�)





How to Look Up a Kanji Character

	If you are not sure of the precise kana reading of a particular kanji, you can look it up by stroke count or by bushu.  Choose Lookup from the Kanji menu, and you will see a dialog box with a slide-rule containing a list of kanji’s, originally sorted by stroke count.  You can use the scroll-bar directly beneath the slide-rule to find the particular kanji you are looking for.

	Alternatively, you can use the stroke count and bushu scroll-bars to move to a particular range of kanji’s quickly.  You then use the slide-rule to choose from a limited list.

	You also have the option of sorting the kanji list by bushu; simply click on the radio button next to the bushu scroll-bar and the kanji’s listed in the slide-rule will automatically resort themselves.

	When you have found the kanji you are looking for, double-click on it or highlight it and then clicking Insert to File.  The kanji will be automati�cally inserted into the current file at the cursor position.





How to Use Radical Lookup to Look Up a Kanji Character

	An alternative to the regular bushu/stroke count lookup, the Radical Lookup method assists in searching for a particular kanji through a selected number of bushu’s that make up the kanji.

	When the Radical Lookup window is opened, it shows roughly 240 buttons, each for a particular bushu arranged by strokes.  Some bushu buttons are linked such that pressing one will automatically search for the others as well.

	Pressing the Search button will produce a sorted list of all kanji’s containing the selected bushu’s. The scroll-bar directly beneath the slide-rule can be used to find the particular kanji being searched for.

	Selecting more than one bushu will significantly reduce the size of this list and, in most circumstances, two bushu’s are adequate in locating the particular kanji.

	Double-clicking on a particular kanji or highlighting it and then clicking Insert to File will automatically insert that kanji into the current file at the cursor position.





How to Enter Any JIS Character

	It is possible for you to enter any character currently defined in the JIS character set, both level 1 and level 2.

	The first method is to choose JIS Table from the Kanji menu.  You will be presented with a large 16×6 table with each JIS character appropri�ately placed according to their JIS coding.  The size of the table is 16×6 for a reason: standard JIS coding starts at hex 21 (first printable non-blank char�acter in the ASCII character set) and goes up to hex 7E (last printable char�acter in the ASCII character set, just before the non-printable Del character).  This corresponds to almost 6 rows of 16 characters each, following the hex coding.  The first character of each row corresponds to the digit zero in the last four bits of the JIS code, the next character representing the digit one, and so on.  The first row of the table represents the digit 2 in the second four bits of the JIS code, the second row represents the digit 3, and so on.

	The JIS character set is designed such that different types of symbols occupy different areas in the 93×93 coding space.  The JIS table JWP uses is divided into pages.  The first page represents the byte 21 (in hex) in the last eight bits of the JIS code.  Definitions of the different pages are:







Page (hex)�Characters��21, 22�Japanese symbols��23�English alphabet and numeric digits��24�Hiragana’s��25�Katakana’s��26�Greek alphabet��27�Russian alphabet��28 to 2F�Reserved��30 to 4F�Level 1 kanji’s��4F to 73�Level 2 kanji’s��

You can move to the next or previous page through the scroll-bar or the Next and Prev buttons.  You can also jump to a particular page by drag�ging the scroll-bar.  The number of the current page (both in hex and in decimal) will be constantly displayed.

	You can insert any character in the table by double-clicking on it or clicking it and then pressing the Insert to File button.

	If you know the JIS coding of the character you want to enter, you can choose JIS Input from the Kanji menu.  Remember that you must enter the JIS code in hex.
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Special Features









How to Use the Japanese–English Dictionary

	JWP comes with a Japanese–English dictionary, kindly donated by Jim Breen� from the Deep South (Australia).  Jim Breen’s dictionary contains English meanings of many common Japanese words; its dictionary and index formats are compatible with MOKE.  Therefore, you have the option of using one single copy of the dictionary for both MOKE and JWP.  Jim Breen con�stantly updates and expands the dictionary; the latest version can always be downloaded via anonymous FTP from ftp.cc.monash.edu.au. 

	You can access the dictionary by choosing Dictionary from the Utilities menu.  JWP allows you to search either by Japanese or English, but not both.  An English entry must be at least 3 letters long.  Pressing the Search button will start the search.

	If any dictionary entry matches your search string, it will be listed.  You can select any line listed an insert it into your file by double-clicking on it or pressing the Insert to File button.

	To keep one single copy of the dictionary for use with JWP, MOKE and Jim Breen’s JDIC, you must make changes to either the JWP.INI file in your Windows directory or the configuration files of MOKE and JDIC.�

By default, JWP displays all entries found in the dictionary containing the search text, including proper names, place names, vulgar and colloquial expressions etc.  You can also restrict the type of entries that JWP displays by censoring undesired entries.

You can open the options dialog box by pressing the Options button.  This dialog box will allow you to add new dictionaries to be searched or remove existing dictionaries.  It also allows you to specify which dictionary should be searched and which should be skipped. Various types of dictionary entries (such as vulgar expressions, etc.) can be excluded from the search, essentially censored.





How to Use the Dynamic Glossary

	It is usually slow to type kanji’s.  JWP has a full dynamic glossary sys�tem to help you with frequently-used phrases.  A dynamic glossary is differ�ent from a normal glossary in that it constantly looks at what you type instead of forcing you to press a magic Glossary key.

	You can access the glossary by choosing Glossary from the Utilities menu.  All the glossary items currently defined will be listed.  You can add a new glossary item by pressing the Add button.  You can also edit an exist�ing glossary item by double-clicking on it or selecting it and pressing the Edit button.

	A glossary item consists of a “short-cut” string, which can either be all-kana or all-English.  If you try to add an item with a short-cut string that is the same as that of an existing glossary item, the new “phrase” will replace the original phrase.  If the short-cut string does not match any existing glossary item, it will be added to the glossary.

	To recall a glossary when typing in the file window, you only need to type the short cut string and JWP will automatically replace the glossary short-cut with the glossary phrase.  Because dynamic glossary items are matched dynamically, avoid using a lot of short-cut strings that are very similar to each other; otherwise, you may overflow the glossary stack and generate an error.

	You have the option of turning off the Dynamic switch on an item so that it will not be matched dynamically.  A non-dynamic glossary item can only be entered through the pop-up glossary list.

	Choose Glossary from the View menu or press the Glossary List button on the iconbar and the glossary list will pop-up on top of JWP.  You can enter any glossary item listed simply by clicking on it.  A glossary item will not show up in the list if it is tagged Hidden (when adding that item) though.

	JWP originally comes with a glossary file consisting of many short-cuts for symbols in the JIS character set.  All of these symbols are originally tagged hidden.  You are welcome to retain only the ones that you feel are useful and add others.





How to Assign Hot-keys to Functions

	One of the flexibilities of JWP is that you can set your own key bind�ings for most of the most used features.  Choose Hotkeys from the Utilities menu and you can assign one hot-key to each function, including Toggle Kana/Text mode, Convert to Kanji, File Save, etc.

	To assign a hot-key to a function, double-click its entry in the list or select it then press Edit.  For most systems, hot-keys are restricted to Shift and Control com�binations of function keys 1 to 12, as well as the shifted and unshifted control keys Ctrl�A to Ctrl�Z.  However, you cannot assign control characters like Ctrl�M and Ctrl�H to functions because they have special meanings within JWP.  JWP automatically saves new hot-key bindings.

	It is strongly recommended that you assign a hot-key to the various kanji look-up functions because it will be the only method that you can access those functions within a Japanese edit control inside a dialog box.





How to Look at JWP Statistics

	JWP keeps its own kanji font cache and other buffers for its internal operations.  Choosing Statistics from the Utilities menu will give you some of the internal statistics, probably useful only to JWP developers.  The numbers shown in the File box include the total number of characters in the current file and the total number of changes that you can undo.





How to Toggle the Iconbar, Status Bar, File Rulers, Kanji List, Glossary List and Special Symbols Display

	You can turn off the iconbar, the status bar, the kanji list, or the file ruler that appears on top of every file window through choices under the View menu.  You can also toggle the glossary list by choosing Glossary or by pressing the Glossary List button on the iconbar.  You can decide whether JWP will display special symbols by selecting Special Symbols from the View menu or by pressing the Special Symbols button on the icon bar.

	If turned on, the following special symbols will be displayed on the screen:



		Space			·

		Tab			»

		Soft return		«

		Hard return		¶



This feature also makes it convenient to edit text originally imported from other text based Japanese formats.





How to Change Options in JWP

	You have control over a number of JWP options that determine the behavior of many JWP features.  Choose Options from the Utilities menu and you will be presented with a dialog box with the current settings to all JWP options.  The following is a description of each applicable option:



Option�Description��Relax margin for punctuation�If selected, JWP will attempt to place Japanese punctuation characters (such as �) and all small kana’s (such as �) beyond the right margin to prevent them from starting a new line.��Show all possibilities in conversion�If selected, JWP will continuously show the list of kanji’s matched whenever a kana-to-kanji conversion is in progess.��3D Dialog Boxes�If selected, JWP will give all dialog boxes a three-dimensional look.��Glossary Disappears after Selection�If selected, the glossary list will disappear after you have selected a glossary item from it.��Retain Changes with Saved File�If selected, when saving a file in the JWP Normal format, changes made to the file will be saved in addition to the text.  Those changes can then be reversed through the undo feature in later sessions.��Option�Description��Conversion bar position�Can be Top, Bottom or Floating.  You can also change this by manually dragging the conversion bar to the new position with the mouse.��Clipboard format�When Japanese text is copied to the clip�board (through the Copy or Cut commands from the Edit menu), such text can be subsequently pasted to another application.  This option will determine what format the text will take when being pasted outside of JWP.��Number of Undo Levels�Specifies the number of levels of undo that JWP is to keep.  JWP attempts to keep as many changes to a document as possible until no more memory is avilable.  Then all redo’s and the oldest changes will be dropped to make room.��
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Working with Files









How to Edit File Summaries

	Every JWP file can contain a “summary”.  There are five items in a file summary: 1) Title, 2) Subject, 3) Author, 4) Keywords, 5) Comments.  It is highly recommended that you include a meaningful summary with every Japanese file that you create because it will greatly enhance the chance of you finding the file again quickly.  As you may know, DOS limits the name of each file to eight upper case characters, hardly adequate to hold an even remotely meaningful Japanese file name.

	You can edit the file summary by choosing Summary from the Edit menu.  It is also recommended that you create a glossary item for the unchanging parts of the summary, such as the Author, so that such text can be entered quickly and painlessly.





How to Find a File

	It is sometimes very difficult to look for a particular Japanese file, named with English characters, especially when the typical file name is restricted to only eight upper case characters.  This is the lame design of DOS that we must all live with.

	JWP has integrated support for finding files hidden somewhere within your machine.  Choose Find from the File menu to access this feature.

	Inside the File Find dialog box, the current directory will be shown in the upper right hand corner.  You can change to a different directory or a different disk drive by double-clicking on the list below it.

	You can indicate whether you want to search only the current direc�tory, the current directory and all subdirectories, the entire disk, or all disk drives on your system.

	Pressing the Search button will put you to another dialog box.  There, you can specify the file names you want to search in (for example, ‘*.jwp’ for JWP files only, ‘*.*’ for all files, ‘*.euc’ for EUC files, or a specific file if you remember its name). You can also type in words to search for in each of the five summary categories.  A file is found if it matches all the criteria; that is, its name matches the file name criteria and, if summary criteria are present, that it is a JWP file, and that each of its summary entry contains the string of words specified in the criteria (not necessary in the beginning).

	The full path names of all the matched files will be listed out after the search.  You can get further information on any file by selecting it and click�ing the Get Info button.  You can open that file by double-clicking it or selecting it and choosing Open.





How to Read and Open Files

	Choose Open from the File menu when you want to open a file that you have previously saved.  JWP can read from many file formats,� including:



		1) JWP’s own JWP format

		2) Enhanced UNIX code (EUC)

		3) Shift JIS

		4) New JIS  (Escape $ B to start kanji’s, Escape ( J to end)

		5) Old JIS  (Escape $ @ to start kanji’s, Escape ( J to end)

		6) NEC JIS  (Escape K to start kanji’s, Escape H to end)



There is also an Auto-detect feature that will automatically detects the input file type, with reasonable accuracy.

	If the file chosen is not in the JWP Normal format, another dialog box will be displayed asking for a confirmation of the file format.  In addition, two options may be set:

·	The option Create Paragraphs, when chosen, will try to create paragraphs out of plain text documents.

·	The option Align kanji’s, when chosen, will automatically insert a tab after an English letter if it is followed by a Japanese character.  This way, all Japanese text will be aligned to discrete positions.  This option is defaulted on and is highly recommended because it enhances printing.

	If you do not remember the name or directory of the file you are look�ing for, click on the Find File button and you will be able to search for the file based on a few criteria.

	JWP remembers the last four files that you have worked on and puts their names at the bottom of the File menu, the most recent file first.  You can open the file quickly by choosing it from the menu instead of going through the Open dialog box.

	If the file is in the JWP Normal format, and if there are changes saved with the document, you will be able to undo the changes that you have made during previous sessions.





How to Create a New File

	You can create a new file window by selecting New from the File menu.  The new file window created will inherit the current option settings.  It will initially be named Untitled.

	If there are templates available, a list will be displayed and you can choose whether to base the new file on an existing template or not.  For more details, see the section “How to Use Templates”.





How to Save a File

	Saving a file works in a similar way as opening it.  You can also specify what file format to save the file in, though most of the time you will probably want to save in JWP Normal format so that all formatting is retained.  Saving a file into another standard format will enable you to share that file with another Japanese application.

	When you try to save a file originally opened in another format,� JWP will ask you whether you would like to replace that file with the JWP-Normal format instead.  JWP will also prompt you for a “File Summary” if you are saving the file for the first time.

	The default, when saving to a non-JWP-Normal format, is the save each paragraph as one long line.  If you turn on the Line Length option and specify a line length, JWP will break the lines at exactly the specified length.

	When the Template file format is chosen, JWP will attempt to create a template based on your current file.  All templates have the extension .TPL.  JWP automatically saves the template in the default templates directory (usually a TEMPLATE sub-directory under the main JWP directory); because of this, you should omit the file’s path when you are saving a template.  Templates not saved within the templates directory cannot be found.

	You should also provide a title to the file summary of the template.  JWP will use this title as the formal name of the template.

	When saving a file in the JWP Normal format, it is possible to save the changes made to the file in addition to the text. The Retain Changes with Saved File option should be selected if changes are to be saved with the file.





How to Use Templates

	Unlike many word processors, templates in JWP are simple, normal document files, the only difference being the extension (.TPL instead of .JWP).  You can open a template file just like a normal file and edit it.  You can also save the template just like a normal file.

	There are advantages of saving a template in Template format, though.  JWP automatically saves any template in the default templates directory (usually a TEMPLATE sub-directory under the main JWP directory), where it must reside in order to be found, provided that you do not explicitly specify a path with the filename.

	The practical use of templates is to provide standardized, automatic settings for different types of documents.  Every time a new file is created (through New from the File menu), JWP will prompt you for a template to base on, if any.  The name of each template listed will be the title that you specified in each template file’s summary.

	For example, you can create a form-letter template that contains the name of the author, the subject, header/footer strings, specified page settings, and base text.  When you create a new file based on this template, it will be as if you have made a copy of that form letter.  All summaries, customized settings and text will appear in the newly-created file.





How to Close a File

	You can close a file by choosing Close from the File menu.  If you have made changes to that file since you last saved it, JWP will ask you to confirm whether you really want to throw those changes away.
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Concepts About Japanese Fonts and Printing

	Printing a Japanese document is significantly different from printing an English document.  It will become apparent almost immediately that many layout features important to an English word processor (such as hyphenation, text justification, proportional spacing, kerning, multiple fonts, character attributes, etc.) take on a much less dominant role in Japanese printing.  On the other hand, many layout features unique to Japanese printing (such as discrete text blocks, vertical writing, etc.) are univer�sally ignored in most English word processors.

	The issue of printing is further complicated by the need to show a page of Japanese text on a computer screen in a way that closely resembles how it will eventually be printed out on the printer.  A user might choose to print Japanese characters in 10 points (about the typical size for Japanese novels), but a 10 point kanji character is very likely not to be readable on the screen (about 8×8 or less in VGA resolution).  As a result, there is always a certain level of magnification involved when displaying Japanese text.

	Currently you can only print Japanese and English text in one size (for now).  Support for multiple font faces and sizes on the same page is planned for a future release.  Three Japanese fonts come with this package: 16×16, 24×24 and 48×48.  On a 24 pin dot matrix printer, the 16×16 font will prob�ably print at 6 points, the 24×24 font at 10 points and the 48×48 font at 18 points.  On a 300 dpi laser printer, the 16×16 font will print at almost 4 points (hardly readable), the 24×24 font at almost 6 points (barely readable) and the 48×48 font at almost 12 points (readable).  When displayed on the screen, however, the 16×16 font is adequate for monitors with resolutions up to 800×600 (Super VGA resolution).  The 24×24 may be more suitable for a monitor with 1024×768 resolution (8514A resolution).�

	In JWP, the kanji font that you want to display on the screen is called the Display Font and the kanji font that you want to print with is called the Print Font.  After you have decided on a print font and a display font, JWP will automatically take care of all scaling and spacing to make sure that what you see on the screen is reasonably close to what you will eventually get from the printer.

	You can change the default font selections by choosing Kanji Fonts from the Kanji menu.  Sometimes, the base resolution of a print font is not enough.  For example, the 48×48 font will print in 11.5 points on a 300 dpi laser printer; you will have to magnify the font 1.5 times to get a 16 point Japanese font.  In JWP, you can specify the exact point size that you want your kana’s and kanji’s to be printed in.  A message in the dialog box will show you exactly what the base resolution of the font means in terms of point sizes.

	The Text Font column refers to the English font that you want to print all English text in.  A font name with an asterisk (*) in front is a font avail�able on your printer as a native font.  It is strongly recommended that you select a text font that is smaller than the size of your kanji print font.  Because JWP is designed to handle mainly Japanese text, each line is exactly the height of a line of Japanese text.  If you choose a text font larger than the kanji printing size, you will have English text intruding into previous lines.

	Remember, though, that any changes in this magnification ratio will affect the look of your screen because JWP automatically renders the print�ing font (in the printing size) with your selected display font.





How to Put in Headers and Footers

	Headers are lines of text that automatically appear at the top of every single printed page.  Similarly, footers appear at the bottom of each page.  You have the option of adding a line of header and a line of footer to any file you print.  Choose Header/Footer from the Edit menu to edit the header or footer of the current file.

	You also have an option of specifying a different header/footer for left and right pages, as well as suppressing headers and footers on the first page of the document.

	A header is always printed one line above the first line of the page, and a footer one line below the last line of the page.  Each header and footer is divided into three pieces: Left, Center and Right.  The Left portions of the header and footer will be aligned to the left margin of the page.  The Center portions are centered, and the Right portions are aligned to the right margin of the page.  If any of the following special text is present in a header or footer, it is expanded:



Text�Expanded into��&L�Title��&S�Subject��&A�Author��&K�Keywords��&C�Comments��&T�Current time��&D�Current date��&P�Page number��&F�Name of the file��&&�The character ‘&’��



How to Set up Page Margins

	You can specify top, bottom, left and right margins for the paper size of your active printer by choosing Page Setup from the Format menu.  Margins can be expressed in inches, centimeters, millimeters, points and pixels (dots).  You are free to choose the measurement that you are most comfortable with, and your choice will be remembered whenever you run JWP again.

	You can also change the page margins individually for each file.  When you change the default margins, any new files that you create will inherit the new margins.

	You can print in landscape by changing the paper orientation option from the Windows Control Panel.  Alternatively, you can specify Landscape as the printing orientation in the dialog box.





How to Print a File

	To print a file, choose Print from the File menu.  Among other options in the printing dialog box, you can specify how you want your English text to align.  To use this feature, however, you Must put a tab after an embedded English string to align the next Japanese character to a dis�crete character boundary.  Otherwise, Japanese text will always follow immediately after the English text, without regard to character boundaries.

	The Short Text justification type (set in the options) indicates the type of justification for printing English text that is sandwiched between Japanese characters.  The most satisfying short-text justification mode appears to be Center, then Justify.  The Long Text justification type (also set in the options) is used to justify text that are long enough to dominate the line. Justify appears to work best so that all English text will be aligned with the right margin of Japanese text.





How to Print Vertically

	JWP supports vertical printing.  Pressing the Vertical Printing button on the iconbar will mark the current file for vertical printing.  Alternatively, the Print Vertically command under the Format menu can be used to toggle between horizontal and vertical printing.

	When vertical printing is turned on, paper orientation is not changed, but all Japanese text printed will be rotated 90 degrees counter-clockwise.  For example, printing the following text horizontally will yield:



�



while printing it vertically will yield:



� 



Vertical printing does not affect English text, but it will affect English text typed in as JASCII. JWP also knows enough not to rotate certain symbols (such as the�pair here) and to offset certain punctuation marks (such as �here).





How to Install More Fonts

	Currently, JWP comes with three Japanese fonts: 16×16, 24×24 and 48×48 �.  If more fonts are released in the future, you can install them by modifying JWP’s initialization file JWP.INI in the Windows directory.  The section [Kanji Fonts] contains information about all the installed Japanese fonts on your JWP set-up.  You should modify this section as follows:



	[Kanji Fonts]

	Number of Kanji Fonts=<Total number of fonts>

	Font #1=K16X16.F00

	Font #2=K24X24.F00

	Font #3=K48X48.F00

			:

			:



Each font is referred to by its number.  In the example above, for instance, font number one refers to the 16×16 font.  You can change the default Base Font and the Print Font by editing the appropriate lines.
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Future Releases of JWP

	Depending on time, I would like to keep enhancing the program.  Among the features tentatively scheduled for the next release are:



		1)  Font attributes (bold, italics, underline, �embed MSDraw \* mergeformat ���, etc.)

		2)  Changing font sizes in the same page

		3)  More paragraph and layout options

		4)  DDE and macros

		5)  Object Linking and Embedding (OLE)

		6)  JWP installation program



	If you have access to the Internet, the official distribution site of JWP for the fore�seeable future is kilroy.Jpl.Nasa.Gov under the directory /pub/misc. There, you will also find archives of JWP’s source code.  Since JWP files are large, please be considerate and only download the package during non-prime hours.

	Another site for JWP is ftp.cc.monash.edu.au maintained by Jim Breen�.  This site has an added advantage of always having the latest versions of the KINFO “Kanji Info” database and the EDICT Japanese-English dictionary.





Support for JWP

	The project that eventually turned into JWP was supported by many people around the world.  Many of them donated code, entered databases, and did numerous editing work to make JWP a reality.  Even more users tested JWP from the very first versions.  Their comments, opinions and bug reports were invaluable to the project.

	If you find errors in the dictionary or in the kanji information data�base, please notify me as soon as possible.  You also are encouraged to communicate any comments, suggestions, and bug reports to me.  I would love to hear from you, if only to know that you are using the program and like it (or hate it).  To get in touch with me, you can either:



		1)  Write to:		Stephen Chung

					34 Bridge Street

					Lane Cove, NSW 2066

					Australia



		2)  Call me at home:	Australia (02) 427-4238



		3)  Send me electronic mail at:



			schung@kilroy.Jpl.Nasa.Gov

			schung@daneel.rdt.monash.edu.au



Keep in mind, however, that my address and phone number is likely to change frequently.  Email is likely to be more reliable.

� Consult the Windows User Manual for details.

� The commercial version of MOKE, however, uses an input method similar to JWP’s.

� “What You See Is What You Get”

� In fact, this document was compiled with Word for Windows 2.0, with Japanese bitmaps pasted in throughout the document.

� As far  as  possible,  this is the radical number used in the Modern Reader’s Japanese-English Character Dictionary,  edited by Andrew Nelson.  Where the classical or historical radical number differs from this,  it is present as a separate C<num> entry in the meanings.

� Grades 1 through 6 indicate Jouyou (�, “common”) grades 1 through 6. Grade 8 indicates general-use characters. Grade 9 indicates Jinmeiyou (�, “for use in names”) characters. If not present, it is a kanji outside these categories.

� If  not  present,  the character is not in the dictionary,  or is considered to be a non-standard version,  in which case it may have a cross-reference  code  in  the  form:  XNnnnn in the meanings field.  (Note that many kanji currently used are what Nelson described as “non-standard”  forms or glyphs.)

� Texts in parentheses corresponds to different okurigana's (�) of a reading.  Texts following a leading dash (�) character represent word endings.

� Jim Breen’s Internet email address is jwb@rdt.monash.edu.au.

� To specify a different loca�tion for the kanji information file, you must change the following lines in JWP’s initialization file JWP.INI in the Windows directory:

	Kanji Info=<directory>\KINFO.DAT

	Kanji Info Index (Stroke)=<directory>\KINFOSTR.DAT

	Kanji Info Index (Bushu)=<directory>\KINFOBSH.DAT

� Jim Breen’s Internet email address is jwb@rdt.monash.edu.au.

� If you decide to keep the dictionary file (EDICT) and index file (EDICT.JDX) in the MOKE / JDIC directory, you should edit the following lines in JWP.INI:

[Dictionary]

Number of Dictionaries=1

Dictionary #1=<directory>\EDICT|<directory>\EDICT.JDX|Yes|

EDICT: Jim Breen's Japanese-English Dictionary 

� Conversion facilities between different formats are provided by Ken Lunde.  His Internet email address is lunde@mv.us.adobe.com.

� Conversion facilities between different formats are provided by Ken Lunde.  His Internet email address is lunde@mv.us.adobe.com.

� JWP’s “Base Font” (i.e., the font to be used in dialog boxes, etc.) is originally set to 16×16.  You can change it by editing the line “Default Base Font=” in JWP.INI.  (See page �pageref ChangingBaseFont�45� for more details)

� Jim Breen’s Internet email address is jwb@rdt.monash.edu.au.
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